Pwnage Tool 2.0 Released


By
Posted on Sunday July 20th, 2008 / 12:08

Κυκλοφόρησε σήμερα η πρώτη έκδοση του PwnageTool 2.0 από την Dev-Team (προς το παρόν μόνο για Mac):

Pwnage v2.0 Dev-Team

Pwnage 2.0 features:

 

  • Activate/Jailbreak/Unlock του iPhone 1st gen με firmware 2.0.
  • Activate/Jailbreak του iPod Touch με firmware 2.0.
  • Activate/Jailbreak του iPhone 3G 
  •  

    Προς το παρόν το PwnageTool 2.0 δεν προσφέρει τη δυνατότητα unlock στα iPhone 3G και για τον λόγο αυτό η εγκατάσταση του bootneuter είναι άσκοπη. Το ξεκλείδωμα του baseband του iPhone 3G αναμένεται (σύντομα?) και θα περιληφθεί στην επόμενη έκδοση του PwnageTool. Ωστόσο, οι χρήστες των iPhone 3G δεν θα μείνουν (εντελώς) παραπονεμένοι καθώς παρέχεται η δυνατότητα jailbreak και εγκατάστασης εφαρμογών από τον Installer και το Cydia.

    To PwnageTool 2.0 δεν προσφέρει (στην τωρινή του έκδσοη) ενσωματωμένο τον Installer, καθώς βρίσκεται στο στάδιο της ανάπτυξης (beta 4).

    Περιμένουμε περισσότερες λεπτομέρειες από την Dev-Team για το εργαλείο. Μέχρι τώρα έχουμε μερικές σημειώσεις με διευκρινήσεις για τυχόν προβλήματα που ίσως προκαλέσει η εφαρμογή.

    Note 1: Just to clear up some confusion over what this actually does: Υes, it jailbreaks and unlocks older iPhones, and jailbreaks iPhone 3Gs and iPod Touches. We only support the 2.0 firmwares.

    Note 2: If you get Error 1600 from iTunes (or if you see in your log a failure to prepare x12220000_4_Recovery.ipsw), try: mkdir “~/Library/iTunes/Device Support” ;  if that directory already exists, remove any files in it.  Then re-run PwnageTool.

    Note 3: If DFU restores are giving you trouble, another route to pwned 2.0 for 1G owners is to use our first pwnage at 1.1.4.  Once you are pwned there, you  can do a normal recovery-mode restore to your custom 2.0 ipsw.  BTW the iPhone does *not* need to be pre-pwned to be able to DFU-restore into a pwned ipsw — it needs to be pre-pwned only for normal recovery-mode restores of custom ipsw’s.

    Μπορείτε να κατεβάσετε το PwnageTool 2.0 από τα παρακάτω Mirrors:

    Mirror 1 – Mirror 2 

    About Vasilis Ananiadis

    Ο ζωντανός θρύλος της Ελληνικής blogόσφαιρας, ο αβυσσαλέος master του SEO, o πρίγκηπας των Social Media, ο τυφώνας των Web Startups, ο οργασμός της ιντερνετικής επιτυχίας. Τώρα και στο twitter: @vananiadis

    Tags: , ,




    6 Responses to “Pwnage Tool 2.0 Released”

    1. konsti says:

      Είμαι ο πρώτος που την πάτησα γιατί βιάστηκα…

      Έτρεξα το εργαλείο, επέλεξα το σωστό firmware για το τηλέφωνο πρώτης γενιάς, αλλά επέλεξα (εσφαλμένα) την επιλογή Update Baseband και (εσφαλμένα) ξεμάρκαρα το Disable Partition Wipe-Out με αποτέλεσμα, όταν έβαλα το τηλέφωνο σε κατάσταση restore και φόρτωσα το “πειραγμένο” ipsw, αφού περίμενα αρκετά λεπτά το iTunes να καθαρίσει τα 16GB (λάθος μεγάλο γιατί τώρα δεν μπορώ να πάω πίσω στο 1.1.4), στην φάση που ο BootNeuter 2.0 λέει πως κάνει αναβάθμιση του Baseband (εντός 2.5 λεπτών) το τηλέφωνο είχε περάσει 5+ λεπτά και δεν προχωρούσε ούτε έβγαζε άλλο μήνυμα.

      Πάτησα Home & Sleep/Power να επανεκκινήσει το τηλέφωνο και αυτό ήταν. Δεν μπορώ ούτε να περάσω ξανά το 2.0 μέσω iTunes 7.7 (error 1600) ούτε να το υποβαθμίσω σε 1.1.4 μέσω iTunes 7.5 (error 1604 & error 20) και έχω φρικάρει…

      Αν τα παιδιά που έχουν μεγαλύτερη εμπειρία ξέρουν κάτι, ας το ποστάρουν… ή πρέπει να το πάω το 9volto.gr μπας και το σώσω;

      Σπίτι δεν πιάνει τίποτα από όσα προσπάθησα να κάνω… είτε DFU, είτε restore… προφανώς, στην αρχική αναβάθμιση του 2.0, το τηλέφωνο κόλλαγε γιατί δεν επικοινωνούσε με το baseband, αφού το flashing δεν φάνηκε να ολοκληρώθηκε.

      Κάθε βοήθεια δεκτή.
      Ευχαριστώ.

    2. manos says:

      Χαλαρωστε ρε παιδια. Μην το κανετε ακομα. Περιμεντε να δουμε τι θα πουν αλλοι! να βγουν tutotials κλπ. Προς τι η βιασύνη;;;;

    3. konsti says:

      Για κάποιον λόγο, με επαναλήψεις (και τύχη) κατάφερα να επαναφέρω το τηλέφωνο στο 1.1.4 με το iTunes 7.5 και το PhoneDriver του iTunes 7.7 (βλέπε σχετική οδηγία του BigBoss)

      Το πρόβλημα είναι πως το baseband είναι κλειδωμένο και το BootNeuter βγάζει σφάλμα.
      Θα δοκιμάσω κάποιες μεθόδους και θα επανέλθω… Η κάρτα SIM της Wind δεν αναγνωρίζεται. Ευτυχώς έχω την αρχική της AT&T και δούλεψα αρχικώς με αυτή (για την υποβάθμιση).

      Θα σας γράψω μόλις επιτυχώς επανέλθω σε πλήρως λειτουργικό 1.1.4 τηλέφωνο.

    4. geod says:

      Διάβασα παραπάνω πως επέλεξες το ‘Update Baseband’ και τώρα στο έχει κλειδώσει! Τι baseband έχεις τώρα?

      Εγώ είχα αναβαθμίσει σε 2.0 κατά λάθοςαλλά το γύρισα σε 1.1.4 από εδώ: iClarified
      http://www.iclarified.com/entry/index.php?enid=1504

    5. To Pwnage αναβαθμίστηκε στην v2.0.1!

      Τα download link του post πλέον δείχνουν στην νέα version

    6. konsti says:

      Όπως έγραψα και στη σελίδα του μεταφρασμένου tutorial, είχα baseband 04.04.05_G και αναβαθμίστηκε (μάλλον το σταμάτησα, πριν ολοκληρωθεί) σε 04.05.04_G του firmware 2.0.

      Κακώς επέλεξα αυτή την λειτουργία στο Pwnage Tool. Δεν ξέρω τι προσφέρει αυτή η αναβάθμιση στο baseband, και κατά πόσο είναι απαραίτητη για την ομαλή λειτουργία του firmware 2.0 σε τηλέφωνα πρώτης γενιάς…

      Αν κάποιος βρει κάτι, ας το ποστάρει. Εγώ κατάφερα και ‘συνέφερα’ το τηλέφωνο, κατεβάζοντας (στο 1.1.4) το BootNeuter μέσω του Installer και ξανα-φλάσαρα το baseband επιτυχώς. Για κάποιο λόγο, σε pwned 1.1.4 που κατάφερα να ‘φορέσω’ στο τηλέφωνο, η αναβάθμιση του BootNeuter που κάνει το pwned firmware ήταν ανεπιτυχής. Ίσως, το BootNeuter που κατεβάζει ο Installer να μην πατσάρει το baseband αλλά να το επαναπρογραμματίζει (βρήκα τα απαραίτητα αρχεία μέσα στο BootNeuter.app φάκελ0). Τέλος πάντων, σώθηκα.