Κενό ασφαλείας στο OS X 10.8 και iOS 6 καθιστά άχρηστες τις εφαρμογές


By
Posted on Friday August 30th, 2013 / 18:30

Apple

Ένα νέο bug που δόθηκε στη δημοσιότητα σήμερα μπορεί να καταστήσει εφαρμογές στο OS X 10.8 και iOS 6 εκτός λειτουργίας. Πρόκειται για μια σειρά αραβικών χαρακτήρων που φαίνεται ότι ενεργοποιεί ένα bug στο CoreText της Apple για την εμφάνιση των γραμματοσειρών στο σύστημα και ως εκ τούτου δεν επηρεάζει άλλα λειτουργικά συστήματα.

Το bug αυτό φαίνεται ότι είχε γνωστοποιηθεί στην Apple πριν από έξι μήνες χωρίς να έχει υπάρξει κάποια δράση από την εταιρεία για να κλείσει την τρύπα. Πάντως, οι beta εκδόσεις των OS X Mavericks και iOS 7 δεν επηρεάζονται από αυτό το πρόβλημα!

Σύμφωνα, λοιπόν, με την αρχική αναφορά το bug αυτό δεν επιτρέπει σε καμία περίπτωση μη εξουσιοδοτημένη πρόσβαση στην συσκευή του χρήστη αλλά μπορεί ενδεχομένως να αχρηστεύσει την εφαρμογή Messages εάν ληφθεί μήνυμα SMS ή iMessage σε iPhone, iPad ή Mac, να προκαλέσει συνεχόμενα crashes σε Safari/Chrome και να αποτρέψει τη σύνδεση μιας συσκευής σε Wi-Fi εάν το όνομα του δικτύου περιλαμβάνει την αλληλουχία των χαρακτήρων αυτών.

Σχολιασμός στο forum

[via 9to5Mac]

About Harry Souris

Apple news, reviews and opinion. Guitar geek. Editor of iPhoneHellas.gr, MacUser.gr & TechGear.gr.

Follow me on twitter and facebook




One Response to “Κενό ασφαλείας στο OS X 10.8 και iOS 6 καθιστά άχρηστες τις εφαρμογές”

  1. […] O nikosgnr του iPhoneHellas forum μας ενημερώνει σχετικά με το GlyphPatch, ένα νέο tweak που κυκλοφόρησε στο Cydia με σκοπό να διορθώσει το κενό ασφαλείας για το οποίο σας ενημερώσαμε πρόσφατα (βλ. bug στο CoreText της Apple για την εμφάνιση γραμματοσειρών): […]