Νέα PwnageTool, redsn0w και ultrasn0w για το unlock του iOS 4.2.1


By
Posted on Monday November 29th, 2010 / 00:50

H dev-Team σήμερα έδωσε στην κυκλοφορία την αναβαθμισμένη έκδοση του ultrasn0w, η οποία είναι συμβατή με τα iPhone 3G και iPhone 3GS με baseband μεγαλύτερες της 05.13.04

Συνοπτικά #1 (redsn0w for OSX + Windows):

  1. Εάν έχετε iPhone 3GS με παλιά bootrom και είστε ήδη unlocked αλλά θέλετε να πάτε στην 4.2.1 περιμένετε μέχρι να βγει ένα unofficial bundle
  2. Χρησιμοποιήστε το redsn0w για OSX ή Windows.  Ενεργοποιήστε το “Install iPad baseband” και αποδεχτείτε την προειδοποίηση.
  3. Όταν τελειώσει η εγκατάσταση της ramdisk, κατεβάστε το ultrasn0w από το Cydia.

Συνοπτικά #2 (PwnageTool for OSX):

  1. Εάν έχετε iPhone 3GS με παλιά bootrom και είστε ήδη unlocked αλλά θέλετε να πάτε στην 4.2.1 περιμένετε μέχρι να βγει ένα unofficial bundle
  2. Εγκαταστήστε το ultrasn0w μέσω του Cydia
  3. Κατεβάστε αυτό: IPSW
  4. Τρέξτε το PwnageTool και δημιουργήστε μια custom 4.1 ipsw. «Πείτε» στο πρόγραμμα ότι θέλετε να χρησιμοποιήσετε την iPad baseband που κατεβάσατε.  Κάντε restore στο iPhone χρησιμοποιώντας την ipsw που μόλις δημιουργήσατε.

Αναλυτικά:

Η 06.15 baseband είναι νεώτερη από τις 05.14 ή 05.15 (στις οποίες δεν δουλεύει το σημερινό unlock). Πολύ απλά αναβαθμίστε στην 06.15 έτσι ώστε να μπορείτε να χρησιμοποιήσετε το νέο αυτό unlock. Η baseband αυτή υπάρχει στην ipsw της 3.2.2 για το iPad την οποία μπορείτε να κατεβάσετε ακόμα (προλάβετε, όμως, γιατί σύντομα δεν θα είναι διαθέσιμη). Το PwnageTool και το redsn0w θα αναβαθμιστούν σύντομα ώστε να γίνει ευκολότερη αυτή η διαδικασία.

  1. Πρώτα έχουμε το “PwnageTool 4.1.3 Unlock Edition”, το οποίο είναι μόνο για Mac. Έχει ένα ειδικό παράθυρο διαλόγου που θα σας ζητάει εάν θέλετε να αναβαθμίσετε στην baseband του iPad. Απαιτείται να έχετε κατεβάσει ήδη την ipsw της 3.2.2 για το iPad.
  2. Mόλις γίνει διαθέσιμο το PwnageTool 4.1.3 θα αναβαθμιστεί και το repo του ultrasn0w: http://repo666.ultrasn0w.com με το ultrasn0w 1.2, που καλύπτει την baseband 01.59.00 για το iPhone 4 και τις 04.26.08, 05.11.07, 05.12.01, 05.13.04, 06.15.00 για τα iPhone 3G και iPhone 3GS.
  3. Τέλος, θα κυκλοφορήσει και μια αναβάθμιση στο redsn0w αργότερα για τους χρήστες Windows με τις ίδιες επιλογές και δυνατότητες.

ΠΡΟΣΟΧΗ!

  1. Δεν υπάρχει τρόπος να κάνετε downgrade την baseband ούτε να την κρύψετε από την Apple. Με αυτόν τον τρόπο χάνετε την εγγύησή σας!
  2. Εάν κυκλοφορήσει κάποια μελλοντική baseband με σημαντική διόρθωση, η οποία είναι της σειρά 05.χχ δεν θα μπορείτε να κάνετε το update (γιατί θα φαίνεται σαν downgrade). Ούτως ή άλλως, βέβαια, αποφεύγετε τις αναβαθμίσεις εφόσον βασίζεστε στο unlock.
  3. Με την έκδοση 4.2.1 και αν έχετε την 06.15 στο iPhone δεν θα μπορείτε να κάνετε restore σε original έκδοση ποτέ ξανά. Θα πρέπει πάντα να χρησιμοποιείτε custom ipsw. Και πάλι, βέβαια, αν βασίζεστε στο unlock θα πρέπει να είστε συνηθισμένοι σε αυτό.
  4. Μην αναβαθμίσετε στην 06.15 εάν δεν το χρειάζεστε!

Αυτή η έκδοση του PwnageTool περιέχει ένα bundle για την 4.2.1 για τους χρήστες iPhone 3G. Για όλους τους άλλους είναι είναι η 4.1! Εάν έχετε iPhone 3GS με την παλιά bootrom, το νέο redsn0w μπορεί να αναλάβει την 4.2.1 (στην πραγματικότητα περιλαμβάνει όλες τις συσκευές, αν και σε κάποιες είναι στη μορφή tethered). Οι χρήστες iPhone 3GS με παλιά bootrom που θέλουν να πάνε στην 4.2.1 δεν πρέπει να χρησιμοποιήσουν αυτό το PwnageTool. Aναβαθμίστε πρώτα στην 4.2.1 και μετά το νέο redsn0w θα κάνει τα υπόλοιπα.

Μπορείτε να κατεβάσετε το νέο PwnageTool από εδώ και το redsn0w εδώ για Windows και εδώ για Mac OS.

Updates… επειδή οι εξελίξεις τρέχουν:

Update #1: There’s an error in the bundle for the iPhone3GS 4.1 that prevents the new baseband from being used.  If you know your way around OSX, please download the fixed bundle, and unzip it if Safari hasn’t already done so.  Then “Show Package Contents” of PwnageTool.app, navigate to Contents->Resources->FirmwareBundles and drop it there.   Otherwise, please wait for the updated PwnageTool, or the OSX version of redsn0w coming soon.

Update #2: The new redsn0w 0.9.6beta5 is out.  It gives both Windows and OSX users the ability to flash the iPad 06.15 baseband on iPhone3G or iPhone3GS.  It fetches the baseband files directly from Apple for now (the only IPSW you ever point it at is the stock IPSW for the FW on your iPhone right now).  There may be a long delay while it’s doing this (their servers are currently getting pounded).

  • OSX (SHA1 a322ec2c9e91993eca21abaf2e655bb44de3d7d4)
  • Windows (SHA1 7250416e17c3aea9838cdfc73712b38b025e2ed0)   (Windows 7 and Vista users, please run redsn0w as Administrator in “XP Compatiblity Mode”)

If you do flash your baseband via redsn0w, please keep it plugged into USB the whole time.  You don’t want your battery to die during the flash process!

Update #3: For those Mac users with an old-bootrom 3GS who really know what they’re doing, here’s a minimal 3GS 4.2.1 bundle that will get you to 4.2.1 without updating your baseband.  Be sure to uncheck “Activate the iPhone” using Expert mode.  To actually jailbreak after you’ve restored with the help of that bundle, please use redsn0w.  If you don’t know how to drop a bundle into PwnageTool.app, please hold off on 4.2.1 until it’s untethered for everyone (or wait for a nice tutorial from somewhere like http://iclarified.com)

Update #4: Our terrific moderators angiepangie, Confucious, sherif_hashim, dhlizard, and Frank55 have done a stupendous job moderating 7700 comments over just the first 12 hours (that’s 10 per minute for half a day!). Hats off to them, and to all of our great commenters who rack up those + points for helping total strangers jailbreak and unlock their iPhones!   That’s what makes this community great :)

Update #5: Unlockers have been reporting mixed results about GPS functionality at 06.15.00.  Until we can track down what differentiates those who retain GPS vs. those who lose it, be conservative and assume you’ll lose GPS at 06.15.00.  As we work on finding the cause (and possibly a fix), please report your personal findings in our comments section.  (Update: early indications are that while 06.15.00 is capable of GPS, it will require some further hacks.  But please still be conservative and assume you will lose GPS at 06.15, in case the hacks don’t work).

Update #6: Developer @sbingner (author of TetherMe) has made some excellent progress devising a new hactivation method that kills two birds with one stone for all you ultrasn0w unlockers.  His tool, “Subscriber Artificial Module (SAM)” tricks your iPhone and iTunes into creating legitimate activation tickets even though you’re unlocked with ultrasn0w.  This means you get the full benefit of push applications, and your battery life increases substantially.  If you’d like to try it out, check out http://www.bingner.com/SAM.html

To help make it easier to try out @sbingner’s tool, we’ve updated redsn0w to include a new “Deactivate” option for the 3G and 3GS.  Use this option *after* you’ve installed SAM…it will remove the normal patches made to lockdownd and let SAM take over.  (sbingner plans on making a button to do this within SAMPrefs too).  Great work, @sbingner!

Σχολιασμός στο forum: PwnageTool 4.1.3 & ultrasn0w 1.2 & redsn0w (Windows) & redsn0w (Mac)

About Harry Souris

Apple news, reviews and opinion. Guitar geek. Editor of iPhoneHellas.gr, MacUser.gr & TechGear.gr.

Follow me on twitter and facebook

Tags: ,




4 Responses to “Νέα PwnageTool, redsn0w και ultrasn0w για το unlock του iOS 4.2.1”

  1. […] This post was mentioned on Twitter by iPhoneHellas and Thodoris  ™, Panos Ser. Panos Ser said: Νέα PwnageTool & ultrasn0w http://goo.gl/fb/f4IMv […]

  2. […] τελευταία έκδοση του Cydia περιλαμβάνεται στο πρόσφατο Redsn0w που κυκλοφόρησε πριν από μερικές ημέρες, ωστόσο αν […]

  3. […] τους με τον πρόσφατο, πολύπλοκο οδηγό της Dev Team (βλ. unlock iOS 4.2.1) έχουν παρατηρήσει ότι το GPS της συσκευής παύει να […]

  4. […] baseband) που θέλουν να ξεκλειδώσουν την συσκευή τους. Το iPad baseband hack για το iOS 4.2.1 δεν προτείνεται σε καμία περίπτωση ως σταθερή λύση […]